Illion Degradation: CBA (Low Success Rate)

Incident Report for Lend Capital

Update

From illion on 20/08/25:

We are continuing to work to address the ongoing issue with many connections to CBA:
Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.
We recently deployed an update, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.
We will provide further updates 21/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 20, 2025 - 14:23 AEST

Update

From illion on 19/08/25:

We are continuing to work to address the ongoing issue with many connections to CBA:
Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.
We recently deployed an update, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.
We will provide further updates 20/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 19, 2025 - 13:21 AEST

Update

From illion on 18/08/25:

We are continuing to work to address the ongoing issue with many connections to CBA:

Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.

We recently deployed an update, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.

We will provide further updates 19/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 18, 2025 - 17:34 AEST

Update

From illion on 15/08/25:

We are continuing to work to address the ongoing issue with many connections to CBA:
Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.

We recently deployed an update, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.

We will provide further updates 18/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 15, 2025 - 12:37 AEST

Update

From illion on 14/08/25:

We are continuing to work to address the ongoing issue with many connections to CBA:
Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.
We deployed an update last night, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.

We will provide further updates 15/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 14, 2025 - 13:05 AEST

Update

From illion on 13/08/25:

We are continuing to work to address the ongoing issue with many connections to CBA:

Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.

We deployed an update last night, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.

We will provide further updates 14/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 13, 2025 - 12:16 AEST

Update

Update direct from illion on 12/08/2025:

We are continuing to work to address the ongoing issue with many connections to CBA:

Many sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.

We deployed an update last night, however this was unsuccessful in fully resolving the issue. We will continue working on this as our highest priority.

We will provide further updates Wednesday 13/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 12, 2025 - 15:45 AEST

Update

Update direct from illion this morning (08/08):

We deployed an update last night at ~11pm to address the 30016 'No Accounts Parsed' error, which has significantly improved CBA success rate. We will be continuing to monitor and optimise the solution, but since the deployment, success rates have been consistently high,

Please note that we are aware of one other ongoing issue with connections to CBA, which is still under investigation:
A small volume of sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.

Resolution of this issue remains the top priority with our Dev team.

We will provide further updates Monday, 11/08, at 12:00pm AEST, or when we have further updates, whichever is sooner.
Posted Aug 08, 2025 - 12:14 AEST

Monitoring

Communication from illion on 01/08/25:

Please be advised that we have deployed an update to address the remaining issues with processing CBA's newly implements MFA prompts. Successful testing has confirmed that the fix we deployed on Tuesday afternoon has resolved these issues.

Note that we are aware of two ongoing issues with connections to CBA, which are under investigation now:

A small volume of sessions are able to successfully complete the login process, however when we attempt to export transaction data for one or more accounts our bank session is unexpectedly ending, preventing us from retrieving data.

We are intermittently seeing many sessions failing with a 30016 'No Accounts Parsed' error code. There have been two causes for this identified.
- In the first (and most common), the bank is incorrectly returning an empty account list - we are working to confirm if there is anything we can implement to mitigate the impact of this issue from the bank.
- In the second, the bank is returning a 'Temporary Password Expired' message during login, which is currently not being handled as expected.

We will provide further updates Monday, 04/08, at 12:00pm AEST.

If further information is required, please contact the illion Open Data Solutions support team at odssupport@illion.com.au
Posted Aug 01, 2025 - 15:35 AEST

Update

Message from illion at 1PM 21/07:

We are continuing to experience occasional degradation of service for CBA in the BankStatements and BankFeeds environments. The frequency of this has reduced, and we are only seeing lowered success rates across a few intervals each day.

Our Dev team's investigation has indicated that many of the failed sessions are seeing errors caused by the bank blocking or closing the accounts, rather than any fault in our system. Repeated attempts to access these accounts through the BankFeeds system appears to be the result of the remaining drops in success rate.
We are continuing to investigate to determine if there are actions that we can take to mitigate.

Please note that we have confirmed that one of our test accounts has been included in the most recent wave of CBA MFA rollouts, meaning that we will be able to test the new systems end to end - this should aid in the resolution of this and other issues.

We will provide further updates next Wednesday 23rd at 12:00pm AEST.
Posted Jul 21, 2025 - 13:04 AEST

Identified

From Illion:

We are continuing to experience occasional degradation of service for CBA in the BankStatements and BankFeeds environments. This has been occurring intermittently since 01/07/25.

Success rates have been varying significantly over the last week, however since the weekend we are seeing greatly improved success rates (though still with some fluctuation). Our Dev team's investigation has indicated that many of the failed session are seeing errors caused by the bank blocking or closing the accounts, rather than any fault in our system. We are continuing to investigate to determine if there are actions that we can take to mitigate.

Please note that we have confirmed that one of our test accounts will be included in the next wave of MFA rollouts, meaning that we will be able to test the new systems end to end - this should aid in the resolution of this and other issues.

We will provide further updates Wednesday 16th at 12:00pm AEST.
Posted Jul 15, 2025 - 08:56 AEST

Investigating

From Illion:

We are currently experiencing a degradation of service for CBA in the BankStatements and BankFeeds environments, caused by timoutouts and failed connection attempts. This has been occurring intermittently from roughly 5pm yesterday, 01/07/25.

Our dev team is investigating the root cause of this issue as a priority.
We will provide further updates at 12:00pm AEST.
Posted Jul 02, 2025 - 09:56 AEST
This incident affects: illion Bank Statements Service.